Electrical Microwave not heating

Feb 14, 2014
36
7
8
50
#1
Gday all
Anyone had issues with their microwave heating. Last night was the first time we have tried to use it in our new 16' panda. Tried it across all power settings for lengthy times and it just does not heat. Any advice?
 

straydingo

Well-Known Member
Jul 4, 2011
1,128
633
113
Melbourne
#3
Could be a few causes, but the most common is the diode to the magnatron (M/w emitter) is fried, so insufficient voltage getting to the emitter to trigger it, or the magnatron itself is fried. (our kitchen one went with a loud bang).
There are also a couple of door switches. If one of those has failed the m/w won't heat but still light up and spin.

If magnatron, its cheaper to replace the whole unit. Even the testing of the other bits may not be worth it.....

But it will be under warranty, so get it checked by dealer
 
Feb 14, 2014
36
7
8
50
#4
Hey all meant to write up how we got on. Took the microwave back and it was exchanged without a hitch. Turns out there have been about ten in the last 12 months that have not worked from the outset.
Cheers
Frank
 

obedb

New Member
Oct 19, 2019
1
0
0
New York
#6
Check the door safety switch. The connection can become faulty and it shuts down the oven and the turntable, but does not shut down the keypad or light. I just had that problem, opened it up and found the connector was burned pulled it off then slid it back on and all is working again. Have planned to replace the slip on part of plug as soon as possible, also clean the slid in part on switch.
Microwave oven review